Back to overview
Downtime
Skyword Accelerator Unavailable
Feb 7, 2025 at 1:30am UTC
Affected services
Skyword Accelerator
Resolved
Feb 7, 2025 at 1:30pm UTC
Skyword Accelerator was restored.
Affected services
Created
Feb 7, 2025 at 1:30am UTC
Skyword Accelerator is currently unavailable due to an unplanned incident.
Affected services